هل اقدر اركب وندوز اكس بي وهمي على باك تراك

تم تحميل الصفحة في 1,7861878 ثانية
هل اقدر اركب وندوز اكس بي وهمي على باك تراك
إنضم
26 مارس 2009
المشاركات
109
الإعجابات
4
النقاط
0
بسم الله الرحمن الرحيم

سلام عليكم ورحمة الله وبركاته

اخواني هل اقدر اركب وندوز اكس بي وهمي على باك تراك

ممكن شرح او البرنامج


<<< راعي نكبات


له احلىى تقيمم للي يساعدني تفكوون يا شله هع
 
إنضم
16 مايو 2008
المشاركات
3,864
الإعجابات
210
النقاط
63
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

والله مدري

بس اللي اعرفه ان فيه برنامج لـ ليونكس للاجهزه الوهميه !؟

بس مادري يركب على توزيعه باك تراك ,
 
إنضم
16 مايو 2008
المشاركات
3,864
الإعجابات
210
النقاط
63
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

تفضل يالغالي حمل برنامج : virtualbox

مــن هـــنــا :24:

يالغلا طبقت الامر هذا للتنصيب ..


dpkg --install virtualbox-3.2_3.2.12-68302~Ubuntu~maverick_i386.deb

بس للأسف ماتنصب !

وطلع الكلام هذا !

[email protected]:~# dpkg --install virtualbox-3.2_3.2.12-68302~Ubuntu~maverick_i386.deb
Selecting previously deselected package virtualbox-3.2.
(Reading database ... 248038 files and directories currently installed.)
Unpacking virtualbox-3.2 (from virtualbox-3.2_3.2.12-68302~Ubuntu~maverick_i386.deb) ...
dpkg: dependency problems prevent configuration of virtualbox-3.2:
virtualbox-3.2 depends on libpython2.6 (>= 2.6); however:
Package libpython2.6 is not installed.
virtualbox-3.2 depends on libqt4-network (>= 4:4.5.3); however:
Version of libqt4-network on system is 4.4.3-0ubuntu1.4.
virtualbox-3.2 depends on libqt4-opengl (>= 4:4.5.3); however:
Version of libqt4-opengl on system is 4.4.3-0ubuntu1.4.
virtualbox-3.2 depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Version of libqtcore4 on system is 4.4.3-0ubuntu1.4.
virtualbox-3.2 depends on libqtgui4 (>= 4:4.7.0~beta1); however:
Version of libqtgui4 on system is 4.4.3-0ubuntu1.4.
virtualbox-3.2 depends on libssl0.9.8 (>= 0.9.8m-1); however:
Version of libssl0.9.8 on system is 0.9.8g-10.1ubuntu2.6.
virtualbox-3.2 depends on libstdc++6 (>= 4.4.0); however:
Version of libstdc++6 on system is 4.3.2-1ubuntu12.
virtualbox-3.2 depends on libxml2 (>= 2.7.4); however:
Version of libxml2 on system is 2.6.32.dfsg-4ubuntu1.1.
dpkg: error processing virtualbox-3.2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
virtualbox-3.2

مع العلم نسخه الباك تراك عندي r2
 

Da7OmE

ExpErt DeveloPer
rank
إنضم
10 نوفمبر 2006
المشاركات
72
الإعجابات
37
النقاط
0
الإقامة
jordan
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

يالغلا طبقت الامر هذا للتنصيب ..





بس للأسف ماتنصب !

وطلع الكلام هذا !




مع العلم نسخه الباك تراك عندي r2

هلا اخوي موجود
بما انك مبتدى بوضح لك شغله
كل البرامج في لينكس تعتمد على مكتبات معينه من الملفات
وهذي الملفات زي ملفات DLL في الوندوز

اذا حبيت تنزل برنامج من موقعه الرسمي او اي موقع كان قبل ماتنزله بتحصل في الموقع
المكتبات اللي يحتاجها البرنامج بعضها يمكن تكون راكبه عندك او تكون باصدارات قديمة
عشان كذا لازم بالطريقه هذي تروح تثبتها يدويا
وبعض البرامج تحصله ينزل لك المكتبات مدموجه مع ملف الديبان حق البرنامج
او تكون في ملف لحالها من نفس الموقع

انا بشرح لك بعض الأخطا اللي طلع عشان تفهم الفكره
virtualbox-3.2 depends on libpython2.6 (>= 2.6); however:
Package libpython2.6 is not installed

هنا يطلب حزمة libpython2.6 (>= 2.6) بشرط يكون الاصدار 2.6 او اعلى منه
وهالحزمه من الاساس ماهي مثبته عندك

virtualbox-3.2 depends on libqt4-network (>= 4:4.5.3); however:
Version of libqt4-network on system is 4.4.3-0ubuntu1.4

هنا يطلب حزمة libqt4-network (>= 4:4.5.3) بشرط تكون 4.5.3 او اعلى منها
والحزمه راكبه في جهازك بس باصدار اقل من المطلوب اللي هو 4.4.3

وباقي الاخطاء تقريبا متشابهه يا ماهي نازله عندك او انها باصدار اقل

واذا بتيت البرنامج من المستودعات غالبا بيقولك ان هالبرنامج بيطلب هالمكتبات
وينزلها لك تلقائي

جرب افتح الطرفيه وثبت البرنامج من المستودعات
كود:
sudo apt-get install virtualbox-3.2
 
إنضم
16 مايو 2008
المشاركات
3,864
الإعجابات
210
النقاط
63
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

هلا اخوي موجود
بما انك مبتدى بوضح لك شغله
كل البرامج في لينكس تعتمد على مكتبات معينه من الملفات
وهذي الملفات زي ملفات dll في الوندوز

اذا حبيت تنزل برنامج من موقعه الرسمي او اي موقع كان قبل ماتنزله بتحصل في الموقع
المكتبات اللي يحتاجها البرنامج بعضها يمكن تكون راكبه عندك او تكون باصدارات قديمة
عشان كذا لازم بالطريقه هذي تروح تثبتها يدويا
وبعض البرامج تحصله ينزل لك المكتبات مدموجه مع ملف الديبان حق البرنامج
او تكون في ملف لحالها من نفس الموقع

انا بشرح لك بعض الأخطا اللي طلع عشان تفهم الفكره
virtualbox-3.2 depends on libpython2.6 (>= 2.6); however:
Package libpython2.6 is not installed

هنا يطلب حزمة libpython2.6 (>= 2.6) بشرط يكون الاصدار 2.6 او اعلى منه
وهالحزمه من الاساس ماهي مثبته عندك

virtualbox-3.2 depends on libqt4-network (>= 4:4.5.3); however:
Version of libqt4-network on system is 4.4.3-0ubuntu1.4

هنا يطلب حزمة libqt4-network (>= 4:4.5.3) بشرط تكون 4.5.3 او اعلى منها
والحزمه راكبه في جهازك بس باصدار اقل من المطلوب اللي هو 4.4.3

وباقي الاخطاء تقريبا متشابهه يا ماهي نازله عندك او انها باصدار اقل

واذا بتيت البرنامج من المستودعات غالبا بيقولك ان هالبرنامج بيطلب هالمكتبات
وينزلها لك تلقائي

جرب افتح الطرفيه وثبت البرنامج من المستودعات
كود:
sudo apt-get install virtualbox-3.2
كلامك كبير يامعلم ..

بس كيف انزل الحزم .. مع اني طبقت الامر اللي قلت لي عليه بس طلع لي

reading package lists... Done
building dependency tree
reading state information... Done
virtualbox-3.2 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
Virtualbox-3.2: Depends: Libpython2.6 (>= 2.6) but it is not installable
depends: Libqt4-network (>= 4:4.5.3) but 4.4.3-0ubuntu1.4 is to be installed
depends: Libqt4-opengl (>= 4:4.5.3) but 4.4.3-0ubuntu1.4 is to be installed
depends: Libqtcore4 (>= 4:4.7.0~beta1) but 4.4.3-0ubuntu1.4 is to be installed
depends: Libqtgui4 (>= 4:4.7.0~beta1) but 4.4.3-0ubuntu1.4 is to be installed
depends: Libssl0.9.8 (>= 0.9.8m-1) but 0.9.8g-10.1ubuntu2.6 is to be installed
depends: Libstdc++6 (>= 4.4.0) but 4.3.2-1ubuntu12 is to be installed
depends: Libxml2 (>= 2.7.4) but 2.6.32.dfsg-4ubuntu1.1 is to be installed
recommends: Libsdl-ttf2.0-0 but it is not going to be installed
recommends: Dkms but it is not going to be installed
recommends: Linux-headers
e: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
ياليت اي واحد يقول لي اذا بنزل حزمه كيف .؟
 

Da7OmE

ExpErt DeveloPer
rank
إنضم
10 نوفمبر 2006
المشاركات
72
الإعجابات
37
النقاط
0
الإقامة
jordan
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

نفذ هالامر في الطرفية

كود:
apt-get -f install
هالامر يسوي اصلاح للحزم واستكمال التنزيل وتثبيتها
للحزم اللي معلقه وغالبا تكون المشكله من النت انه يتحمل الملف
ويفصل ومايقدريرجع يكمل التحميل احيانا

لتثبيت اي حزمه ناخذ اسمها ونظيفه بعد
كود:
apt-get install
مع امر الاصلاح راح ينزل لك الحزم

اذا خلص امر الاصلاح وماشتغل معك البرنامج
نزل هالحزمتين

كود:
apt-get install Libsdl-ttf2.0-0 Dkms
 
إنضم
16 مايو 2008
المشاركات
3,864
الإعجابات
210
النقاط
63
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

طبقت الاوامر ..

بس للأسف كـ العاده مسكره بوجهي :(

شوف

[email protected]:~# apt-get -f install
reading package lists... Done
building dependency tree
reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~# apt-get install libpython2.6
reading package lists... Done
building dependency tree
reading state information... Done
package libpython2.6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
e: Package libpython2.6 has no installation candidate
[email protected]:~# apt-get install libsdl-ttf2.0-0 dkms
reading package lists... Done
building dependency tree
reading state information... Done
e: Couldn't find package libsdl-ttf2.0-0
[email protected]:~#
 

Da7OmE

ExpErt DeveloPer
rank
إنضم
10 نوفمبر 2006
المشاركات
72
الإعجابات
37
النقاط
0
الإقامة
jordan
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

جرب شغل البرنامج
من القائمة وبعدين system وتحصله باسم Oracle VM VirtualBox

او من الطرفية اكتب
VirtualBox
 
إنضم
16 مايو 2008
المشاركات
3,864
الإعجابات
210
النقاط
63
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

الحمد لله تم حل المشكله .. عن طريق الامر .

apt-get install virtualbox-ose
تم التنصيب بنجاح والبرنامج اشتغل تمام ..
 
إنضم
16 مايو 2008
المشاركات
3,864
الإعجابات
210
النقاط
63
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

بس الحين علقت بمخي ..

ليش مانصب الاول ونصب الثاني وش الفرق بين الاوامر !!

مع انو يوم بدء ينصب اتصل بموقع اوفيس سكيورتي ..
 

Da7OmE

ExpErt DeveloPer
rank
إنضم
10 نوفمبر 2006
المشاركات
72
الإعجابات
37
النقاط
0
الإقامة
jordan
رد: هل اقدر اركب وندوز اكس بي وهمي على باك تراك

بس الحين علقت بمخي ..

ليش مانصب الاول ونصب الثاني وش الفرق بين الاوامر !!

مع انو يوم بدء ينصب اتصل بموقع اوفيس سكيورتي ..
الاول / المصدر مغلق ويجي على هيئة ملف قابل للتشغيل
هو للاستخدام الشخصي غالبا تحت شروط وضوابط الشركة المنتجه

الثاني / مفتوح المصدر مع كامل الحزم المفتوحة المصدر اي قابلة للتعديل
تحت شروط وضوابط غنو العالمية

للمستخدم العادي اللي مايبي يطور الاول افضل له لانه اقل حجم وماياخذ مساحه
الثاني للي يبي يطور في نفس البرنامج

مميزات الاول في موقعهم انهم ضايفين فيه دعمه لـ
USB 1.1 و USB 2.0 و التحكم بسطح المكتب البعيد RDP

اما الثاني بـس ميزة VNC (Virtual Network Computing)
 

الأعضاء النشطين حاليآ الذين يشاهدون هذا الموضوع (1 عضو و 0 ضيف)

خيارات الاستايل

نوع الخط
مودك
اخفاء السايدر بار OFF
توسيط المنتدى OFF
فصل الأقسام OFF
الأقسام الفرعية OFF
عرض المشاركات
حجم الخط
معلومات العضو OFF
إخفاء التوقيع OFF

إرجاع خيارات الإستايل